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Introduction

TaskTime makes keeping track of time spent on multiple client projects easy and 
efficient. With TaskTime you can track any number of clients and any number of projects 
for each client. 

• Since you can have more than one project open at a time it is easy to switch between 
projects on the fly. 

• Tracking expenses has never been easier. Each expense item can have an individual 
tax rate.

• Keep project specific notes of any length and detail.

• Set a separate currency symbol on a project-by-project basis.

• Track the status of each project.

• Use the Project Manager to add, delete, rename, and store projects.

• Link documents, applications, folders, and web/email addresses to any project.

• Minimize project windows to a small, floating timer controller window.
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Getting Started

The first thing you will need to do in order to use TaskTime is add at least one client. 

Choose Manage Projects and Clients under the File menu and click on the Clients tab. 
To add your first client click the “+” button under the Clients list. In the sheet that drops 
down fill in a clientʼs name. NOTE: Client names should not contain dashes (-). If 
desired, you can also fill in the rest of the client information but only the name field must 
be filled in. Click the Add button. When you are finished adding clients, you can close 
the Clients window. 

Under the File menu choose New Project. The Project Manager window will appear and 
the New Project sheet will be shown. Select a client using the popup menu. Enter a 
project name and the rate that you will be charging the client for your work on the 
project. Click OK.

The Project Sessions window will then open and the New Project sheet will drop down.
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Select a client in the popup menu. Enter a name for the project (project names should 
not contain dashes (-)). Enter a rate for the project. If desired, enter an invoice number. 
NOTE: If you have activated AutoNumbering in the Preferences the invoice field will 
have been filled in automatically.

NOTE: You can edit the default rate on the project window when it opens. You can also 
set session by session rates on the project window.

The Project Sessions Window

Running A Session
To start a session click the clock button. The icon will change to a stop icon.
You can pause and resume a session using the pause button.*
Click the stop icon to stop a session.

Editing Sessions: 
Click in any column to edit session data. If necessary, TaskTime will recalculate the 
Start, End, and/or Time columns to accommodate changes. Time Charges and Total 
Charges will also be adjusted as necessary.
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Session Notes
By clicking the arrow button (below the sessions list) you can reveal the session notes 
field. When a session is selected in the sessions list this field becomes active and any 
session specific notes can be entered. There is a preference option to include these 
notes in invoices. 
NOTE: If “Show Details” is unchecked in the preferences, session notes will be aligned 
with session descriptions in the project invoice.

The Controller Button - switches to the controller window. To switch back to the full 
project window just close the controller window.

The Regular Items Button - If no session is selected in the list the Regular Descriptions 
menu editor will appear. Commonly used descriptions can be added here. You can set a 
default rate for each Regular Item. Once added, these descriptions can be selected in 
the menu to put them into the description column of the currently selected session. 

* The pause function is intended to be used for short breaks. For longer interruptions it is 
recommended that the session be ended and a new session begun when work resumes.
The Status Popup - shows the Status of a project:
" - Begun
" - In Progress (blue indicator)
" - On Hold (silver indicator)
" - Invoice Sent (orange indicator)"
" - Overdue (red indicator)
" - Paid (green indicator)
" - Completed (gold indicator)

NOTE: For each of the above status types a separate date is saved (except for In 
Progress) to indicate when each project stage began. All of these date can be edited 
except the “In Progress” date which is always automatically set to the current date. 
Status descriptions can be edited by selecting “Edit...” in the status menu.

The Delete Button - deletes a selected session. Running or paused sessions must be 
stopped before they can be deleted.

THE CHECK BOXES - use the check boxes to indicate if a session has been billed or 
not (i.e.. if an invoice has been sent for the session). Sessions marked as billed will not 
be included in subsequent invoices. There are options to automate this in the 
Preferences.
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Tracking Expenses

Access the Expenses by clicking the Expenses Icon...

To add an expense click the “+”. The Expenses sheet will appear. Enter a description 
and amount for the expense. If desired, enter a tax amount for the expense. Click OK.

To edit an expense click in the Description, Amount, or Tax column of the item to be 
edited.

Tracking Flat Rate Items
Flat rate items are any items that are billed by a fixed amount rather than by the amount 
of time spent on the item.

Access the Flat Rate Items by clicking the Flat Rate icon.

To add a flat rate item click the “+”. A new item with the current date will be added to the 
list. Enter the Description and Amount for the new item

To edit an expense click in the Date, Description, or Amount column of the item to be 
edited.

Regular Expenses and Flat Rate Items

Expense items or flat rate items that you use frequently can be added to TaskTime by 
clicking the Regular Items button on the Expenses or Flat Rate tabs. This brings up the 
corresponding Regular Items sheet. Items added to Regular Item lists are accessible 
from any project and can be added to projects by double-click on them in the lists.

Linking to Resources

You can add links to files, folders, and applications by dragging them to the Resource 
Links list in the Resources drawer.

Double-click an item in the list to open it.
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Preferences
To access the Preferences, choose Preferences... under the TaskTime menu.
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The General Pane - The Default Currency Symbol can be set here as can the Default 
Rate.

Default Rate will be used for all sessions unless edited individually in the project 
window.

The Billed Sessions buttons control whether sessions are checked after an invoice for 
the sessions has been sent.

Session Rounding - session times can be rounded to the nearest number of minutes as 
selected in the popup menu.

AutoPause - if more than one project is open and a session is started on one of them 
any other running projects are paused.

AutoSave - saves projects at the selected interval

Controller Placement - controls where controller windows are placed on the screen

The Personal Info Pane - The information that you enter here will be in your invoices. 
Any blank fields are just ignored.
The Message field can be used for any text you wish to display at the bottom of your 
invoice. Text in this field is printed in blue on your invoices.

The Invoice Pane - The “Include in invoices” section allows  you to select what types of  
data you want displayed in invoices.

AutoNumber - if checked invoices will be automatically number in sequence starting 
with the number entered into the “Number from” field. Click the Set button to set the 
entered number as the number from which all future invoices will be numbered.

Set status of emailed invoices to Invoice Sent - if checked the status of a project will 
automatically be set to Invoice Sent and the status date will be set to the current date 
when the email button is clicked in the Invoice window.

Default Invoice Font Settings - select the default font and font size for invoices. These 
settings can be modified for individual invoices on the Invoice window that comes up 
when an invoice is generated.

Default Travel Rate: set the default rate per mile or kilometer for travel expense billing

Invoice Graphic: Click the Select button to choose a graphic file to be used at the top of 
invoices. NOTE: Graphic images must have the width/height ratio of 6.6:1 and must be 
at least 500 x 75 pixels.
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NOTE: The Summary Radio Button: TaskTime can subtotal sessions by Regular Items 
descriptions. Eg. “Web Design”, “Graphic Design”, “Content Creation”, etc. (see Regular 
Items Button on p.4).  Select the Summary radio button to activate this option.

The Text Pane - The words and phrases on this tab are used in invoices. Edit any or all 
of them as desired. Click the Revert to Defaults button to revert all fields to their original 
default text.

The Backup Pane - Click the Select button to choose or change a backup location. 
Whenever a backup is performed all TaskTime data will be copied to this location. 
Enter a number in the “days” field to specify how often automatic backup should be 
performed. 

Restore: Use this option to restore lost or corrupted data.

The Sync Pane - If you have Dropbox installed you can use it to keep your TaskTime4 
data synced between computers. 

The Project Manager

Access the Project and Client Manager from the TaskTime menu.
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The Project Manager can be used to add, delete, rename, open, and store projects.

The Modify button allows you to:
1. Store a project file. Storing a project allows you to place a project anywhere on your 
computer. This is handy if you wish to keep completed projects for future reference 
rather than deleting them. Stored project can be imported back into TaskTime using the 
Import Stored Project... menu item under the TaskTime menu.

When you store a project it is removed from the Project list in the Project Manager 
window and from the Project menu.

Click the Set button to designate the selected project as the default project. If a default 
project has been set it will open automatically when TaskTime is launched.

2. Rename a project.

3. Set a project as the default project (opens when TaskTime is launched) or remove a 
default project designation.

Projects in the list can be sorted by Status, Name, or Invoice Number by clicking on the 
column headings.

The Client Manager
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To add a client click the “+” button under the Clients list. 

In  the sheet that drops down fill in a clientʼs name. If desired, you can also fill in the rest  
of the client information but only the name field must be filled in. 

Click the Add button.  

Clients can also be added from your Address Book. To do so click the Address Book 
icon. After a short delay (depending on the number of people in your Address Book)  the 
Address Book sheet will drop down with a list of all of your contacts. To add a contact to 
TaskTime as a client select the name in the list and click the “Add” button.  

To edit a clientʼs data select the client in the list and click the Edit (pencil) button. 

To remove a client select the client in the list and click the “-” button.

If an email address has been entered for the selected client, clicking the Email link will 
create an email message addressed to the clientʼs email  address. 

NOTE: In versions prior to 3.3 there was no Company field. For clients added with 
earlier versions you may have entered the company name in the Name field (now the 
Contact Name field) and may now  wish to move it to the Company Name field. To do 
this select the client in the list and click the Edit (pencil) button.

Project Invoice Options

To access the Invoice Options click the Invoice tab in a project window. 

The Project Invoice Options allow you to:
- edit the projectʼs invoice number (leave the field empty if you do not wish to have an 
invoice number on the invoice)
- enter an ID number (purchase order, supplier number, etc.) (leave the field empty if 
you do not wish to have an ID number on the invoice)
- enter a balance owing if appropriate
- enter a credit if appropriate
- enter a discount amount
- set a project specific currency symbol
- enter a project specific special message

About Special Messages:
In the Invoice tab of the Preferences window you can enter a message to be displayed 
on all invoices. Entering a Special Message in a projectʼs Invoice Options tab is a 
means of displaying a message on an invoice that is specific to the individual project.
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Project Searches

To search for a project by name or to search for a word or phrase within the content of 
projects, choose Search under the Edit menu to bring up the search window.

Reports

General Reports: To generate a report choose Make Report... from the Options menu. 
A dialog will appear allowing you to choose a report type. 

Choosing “All Clients” means all clients will be included in the report. Choosing a 
particular client in the popup menu will result in a report of invoices for that client only.
The top checkboxes allow you to select the type of data to be included in the report.
Checking the date checkbox allows you to select a date range for the invoices to be 
included in the report.
Checking the Select by Status box allows you to select the status of invoices to be 
included in the report.

Annual Reports: An annual report lists all projects for a specified year that have been 
paid for. Select “Make Annual Report...” from the Options menu.

Daily Reports: Daily reports (Options menu) show all sessions run on a specified day.

Creating Invoices

NOTE: General invoice information can be entered on the Invoice tab of the 
Preferences window. Invoice AutoNumbering can also be turned on or off in the 
Preferences Window.

To create an invoice choose “Make Invoice...” from the File menu.
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Once an invoice is generated you have several options:
The Calendar Button - edit the invoice date

The Clipboard Button- use this button to copy the invoice to the clipboard if you want to 
paste it into a document such as an email message.

The Save Button - saves the invoice disk as a PDF file

The Print Button - prints the invoice

The Email Button - creates a Mail email message with the invoice as an attachment.

The Settings Button - opens the Custom Settings sheet

Font and Size Menues - Choose a font or change the size of the text in the invoice.

QuickSessions

Sometimes you may want to quickly capture working time (e.g.. time spent on the phone 
with a client) that will need to be billed. The QuickSession feature makes this possible.

When QuickSession is selected from the File menu (or Command + Option + Q is 
pressed) the QuickSessions window will appear with the session already running. The 
session can be paused and resumed if necessary. Once the session is stopped you can 
add it to any existing project or create a new project for it to be added to.

If New Project is selected in the popup menu, clicking the Add button will bring up the 
new project dialog.

Menu Items

These menu items may not be self-explanatory:

File>Save Project Link
" This option creates a link (alias) to a project. Many Mac programs (OmniPlan, 
" Merlin, Process, Together, Things, Yojimbo, etc.) accommodate links to files and 
" documents. If you use such a program you can add a link to a particular 
" TaskTime project to your workflow by dragging a Project Link to the program 
" you are using.
File>Project Folder Synchronization
" This options allows you to synchronize TaskTime data between two connected
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" computers.
File>Import Stored Project
" TaskTime allows you to store project files is a folder of your choosing. 
" Occasionally, you may wish to reactivate a project file. This menu option allows
" you to do this.
File>Print Sessions Log
" Allows you to print a log of the current projectʼs sessions
File>Export Data
" Select comma or tab delimiter to export project data in a format that it can then 
" be imported into another program. 

" To export a project so that it can be imported into another TaskTime project "select 
the TaskTime delimiter radio button. (See Team Projects for more on 
" this.)

Sessions>Add Session
" This can be handy if you want to add a session of a predetermined duration. Add 
" the session using this menu item then click in the Time column to enter the 
" duration of the session. Start and End times will be automatically calculated to 
" correspond with the duration you enter.

Team Projects

TaskTime can manage projects where a team of people work together on a project to 
complete it.

Each team member works independently using his or her own copy of TaskTime. He or 
she can run sessions, enter expenses, enter flat rate items, and keep project notes as 
the work progresses.

When a team member completes his or her work on the project the member exports his 
or her work to a data file by choosing “Export Project Data” from the File menu. In the 
Export window that pops up the TaskTime radio button in the delimiter section should be 
chosen. When the Export button is clicked a standard “Save” dialog appears allowing 
the team member to name the export file and choose a save location.

Team members send their exported data files to the team leader.

The team leader opens or creates a project into which the team membersʼ data files will 
be imported. The leader then chooses “Import Project Data” from the File menu to 
import the data files.

Once all of the team member data files have been imported, the team leaded can then 
create an invoice for the collected data and send it off to the appropriate client.
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Syncing Data Between Computers

Syncing Connected Computers: If you can physically connect two computers you can 
use the “Project Folder Synchronization” option under the File menu to sync TaskTime 
data between two computers. 

Syncing Unconnected Computers: All TaskTime data is stored in a folder called 
"TaskTime Projects" which is located in your User>Library>Application Support folder. 
Copying this folder from one computer to another syncs all project and client data. You 
can use a portable drive (flash drive) to transport the data between computers. 

You can also sync data between any number of computers using DropBox. See the 
Sync page in the Preferences window.
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Contact, Credits, and Legal Disclaimer

Visit ToThePoint Software's website:
www.ttpsoftware.com

Contact ToThePoint Software:
To send feedback, ask questions, make feature requests, or report bugs, 
please send email to:
contact@ttpsoftware.com

Credits
TaskTime was made with REALbasic. Download a free demo of REALbasic 
from www.realsoftware.com. Many thanks to the REALbasic programming 
community for their generous sharing of knowledge and resources.

Special thanks to the many TaskTime users who have taken the time to send 
their very helpful feedback, suggestions, and encouragement. 

Thanks to Studio Gibbous (www.gibbous.ca) for contributing the cool clock 
design used in the program icon.

Thanks to Toby Rush for the PDF classes used to create PDF email 
attachments and to save invoices as PDF files.

Legal Disclaimer
TaskTime IS PROVIDED AS IS, & WITHOUT WARRANTY OF ANY KIND, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. YOU MAY 
REDISTRIBUTE THE ORIGINAL APPLICATION WITHOUT RESTRICTION, 
PROVIDED YOU INCLUDE THIS FILE AND DO NOT CHARGE ANY FEES FOR 
ITS DISTRIBUTION OR USE. USE AT YOUR OWN RISK... IN NO EVENT WILL 
THE AUTHOR OF THIS PROGRAM BE LIABLE FOR ANY DAMAGES, INCLUDING 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES, 
ARISING OUT OF THE USE OF OR INABILITY TO USE THIS PROGRAM 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS 
OR SERVICES, OR LOSS OF USE, DATA, OR PROFITS), HOWEVER CAUSED 
AND WHETHER UNDER THEORY OF CONTRACT, TORT (INCLUDING 
NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF THE AUTHOR 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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